in Planet Debian Blogging ~ read.

Is using Octopress a good idea?

Octopress seems to become more popular these days. As it looks great at a first view, I see two problems.

Ruby 1.9.2

All documentations and howtos requires to install ruby 1.9.2 via rvm. Maybe anybody can tell me, why I could not just install the ruby1.9.1 package which is in fact 1.9.2.0?

Comments

Optopress doesn't support comments itself. I found 2 solutions for this problem. The most used is just to use Disqus, the other one to live without comments.

I dislike the idea to embed external resources for privacy reasons and to rely on stuff I don't have under my own control. Is there any alternative solution beside disqus which isn't hosted offside?